System requirements Skip Navigation

System requirements

CylanceGUARD
requires the following:
  • CylancePROTECT Desktop
    agent,
    BlackBerry Protect
    app, and
    CylanceOPTICS
    agent installed on the endpoints.
  • CylancePERSONA
    and
    CylanceGATEWAY
    agents installed on the endpoints (for
    CylanceGUARD
    Advanced subscriptions)
  • The latest
    Google
    Authenticator app is required to log in to the
    CylanceGUARD
    console using multi-factor authentication (MFA).
Requirement
Description
Agent versions
  • Windows
    and
    Linux
    :
    CylancePROTECT Desktop
    agent 1580 or later
  • macOS
    :
    CylancePROTECT Desktop
    1584 or later
  • Android
    and
    iOS
    :
    BlackBerry Protect
    app 2.0 or later
  • CylanceOPTICS
    2.5 or later
  • CylancePERSONA Desktop
    1.2 or later
  • CylanceGATEWAY
    (desktop agent) 1.4 or later
Operating system versions
Data storage and collection
CylanceGUARD
collects data that is natively collected by
CylancePROTECT
and
CylanceOPTICS
. Potential forensic data sets may be collected in the case of an incident. Data collection includes information contained in both
CylancePROTECT
and
CylanceOPTICS
alerts as well as data captured through the Package Deploy (Refract) and InstaQuery. Package Deploy has the ability to pull forensic artifacts from the file system at almost any level, while InstaQuery returns filesystem, registry, process, and network information from the customer environment.