Mise à jour manuelle du pilote Linux Passer la navigation

Mise à jour manuelle du pilote
Linux

Lorsque vous mettez à niveau le kernel sur votre terminal
Linux
, vous devez vous assurer que le terminal exécute un pilote qui le prend en charge. Lorsqu'une distribution
Linux
publie une mise à jour,
BlackBerry
crée un pilote
Linux
mis à jour et le rend disponible depuis la console de gestion. Un package de mise à jour de pilote est disponible uniquement s'il existe une version plus récente que celle incluse dans la version de l'agent.
BlackBerry
recommande de mettre à niveau l'agent vers la version 3.1 ou ultérieures, ce qui active une fonctionnalité permettant à l'agent de mettre automatiquement à jour le pilote
Linux
après la détection d'un kernel mis à jour, dès qu'il est disponible. Si vous exécutez les versions 3.0 ou 2.1.1590 de l'agent, ou si vous choisissez de ne pas utiliser la fonction de mise à jour automatique du pilote
Linux
, vous devez installer manuellement un pilote pris en charge pour le kernel
Linux
. Vous pouvez utiliser les outils et méthodes de votre entreprise pour déployer les pilotes compatibles sur vos terminaux.
  1. Sur la barre de menus de la console de gestion, cliquez sur
    Paramètres > Déploiement
    .
  2. Dans la liste
    Produit
    , sélectionnez
    Pilote CylancePROTECT
    .
  3. Dans la liste
    Système d'exploitation
    , sélectionnez le système d'exploitation pour lequel vous souhaitez télécharger le pilote.
  4. Dans la liste
    Version
    , sélectionnez la version du pilote.
  5. Dans la liste
    Format
    , sélectionnez le format du pilote.
  6. Cliquez sur
    Télécharger
    .
  7. Pour mettre à niveau le package RPM, utilisez l'une des commandes suivantes :
    Collez les deux pilotes dans la même ligne de commande et remplacez « xx » par le numéro de version du package :
    Distribution
    Commandes
    Oracle
     6,
    Oracle
    UEK 6
    rpm -Uvh CylancePROTECTOpenDriver-xx.el6.noarch.rpm CylancePROTECTDriver-
    xx
    .el6.noarch.rpm
    CentOS
     7, RHEL 7,
    Oracle
     7,
    Oracle
    UEK 7
    rpm -Uvh CylancePROTECTOpenDriver-xx.el7.x86_64.rpm CylancePROTECTDriver-
    xx
    .el7.x86_64.rpm
    Amazon
    Linux
    2
    rpm -Uvh CylancePROTECTOpenDriver-xx.amzn2.x86_64.rpm CylancePROTECTDriver-
    xx
    .amzn2.x86_64.rpm
    SUSE
    Linux
    Enterprise Server
    rpm -Uvh CylancePROTECTOpenDriver-xx.x86_64.rpm CylancePROTECTDriver-
    xx
    .x86_64.rpm
    Prise en charge des distributions 32 bits
    Ubuntu
    et Xubuntu
    • Installez les dépendances à l'aide de la commande suivante :
      sudo apt-get update -y && sudo apt-get install
    • Installez les packages DEB
      CylancePROTECT Desktop
      du pilote à l'aide des commandes suivantes :
      dpkg -i cylance-protect-open-driver_xx_i386_32.deb dpkg -i cylance-protect-driver_xx_i386_32.deb
    Prise en charge des distributions 64 bits
    Ubuntu
    , Xubuntu et Debian
    • Installez les dépendances à l'aide de la commande suivante :
      sudo apt-get update -y && sudo apt-get install
    • Installez les packages DEB
      CylancePROTECT Desktop
      du pilote à l'aide des commandes suivantes :
      dpkg -i cylance-protect-open-driver_
      xx
      _amd64.deb dpkg -i cylance-protect-driver_
      xx
      _amd64.deb
  8. Redémarrez le service à l'aide de la commande suivante :
    systemctl start cylancesvc
    .