Compatibility matrix: CylancePROTECT Desktop agent Skip Navigation

Compatibility matrix:
CylancePROTECT Desktop
agent

When a third-party vendor ends support for any of their products or services,
BlackBerry
ends support for those products or services as well. For information about the software lifecycle for
BlackBerry
enterprise products, as well as information about legacy OS support, see the BlackBerry Enterprise Software Lifecycle Reference Guide and CylancePROTECT Desktop legacy OS support.
For more information about
CylancePROTECT Desktop
requirements, see the CylancePROTECT Desktop requirements.

Support definitions

  • NS: Not supported.
    BlackBerry
    does not support the configuration.
  • Sup: Supported.
    BlackBerry
    supports the configuration.
  • O: Pending.
    BlackBerry
    does not yet support the configuration, but is currently assessing the third-party component for compatibility.

Microsoft

OS
3.2
3.1
3.0
1578
Windows
365 (Business, Enterprise)
Sup
Sup
NS
NS
Windows Server
2022 (Standard, Data Center & Server Core)
Sup
Sup
Sup
NS
Windows Server
2019 (Standard, Data Center & Server Core)
Sup
Sup
Sup
Sup
Windows Server
2016 (Standard, Data Center, Essentials & Server Core)
Sup
Sup
Sup
Sup
Windows Server
2012 R2 (Standard, Data Center, Essentials, Server Core, Embedded & Foundation)
Sup
Sup
Sup
Sup
Windows Server
2012 (Standard, Data Center, Essentials, Server Core, Embedded & Foundation)
NS
Sup
Sup
Sup
Windows
11 (23H2)
Sup
Sup
2
NS
NS
Windows
11 (22H2)
1
Sup
Sup
Sup
NS
Windows
11 (21H2)
1
Sup
Sup
Sup
NS
Windows
10 (22H2)
1
Sup
Sup
NS
NS
Windows
10 (21H2)
1
Sup
Sup
Sup
NS
Windows
10 (21H1)
1
Sup
Sup
Sup
NS
Windows
10 (20H2)
1
Sup
Sup
Sup
Sup
Windows
10 (2004)
1
NS
NS
Sup
Sup
Windows
10 (1809 LTSC)
1
Sup
Sup
Sup
Sup
Windows
8.1
Sup
Sup
Sup
Sup
Windows
7
NS
Sup
Sup
Sup
1
Windows
10 and
Windows
11 IoT versions are not supported.
2
Supported for 3.1.1003 only.

Apple

OS
3.2
3.1
3.0
macOS
14 (Sonoma)
Sup
NS
NS
macOS
13 (Ventura)
Sup
Sup
NS
macOS
12 (Monterey)
Sup
Sup
Sup
macOS
11 (Big Sur)
Sup
Sup
Sup
macOS
10.15 (Catalina)
Sup
Sup
Sup

Linux

For a list of supported Linux drivers and kernels, download the spreadsheet here.
OS
3.2
3.1
3.0
1590
Ubuntu
Ubuntu
22.04 LTS
Sup
Sup
NS
NS
Ubuntu
20.04 LTS
Sup
Sup
Sup
Sup
Ubuntu
18.04 LTS
Sup
Sup
Sup
Sup
SUSE
Linux
Enterprise
SUSE
Linux
Enterprise Server 15
Sup
Sup
Sup
Sup
SUSE
Linux
Enterprise Server 12 SP5
Sup
Sup
Sup
Sup
Red Hat
Enterprise
Linux
Red Hat
Enterprise
Linux
9
Sup
Sup
1
NS
NS
Red Hat
Enterprise
Linux
8
Sup
Sup
Sup
Sup
Red Hat
Enterprise
Linux
7
Sup
Sup
Sup
Sup
CentOS
Linux
distributions
CentOS
8
Sup
Sup
Sup
Sup
CentOS
7
Sup
Sup
Sup
Sup
Oracle
Linux
Server
Oracle
Linux
Server 9
Sup
Sup
1
NS
NS
Oracle
Linux
Server 8
Sup
Sup
Sup
Sup
Oracle
Linux
Server 7
Sup
Sup
Sup
Sup
Oracle
Linux
Server UEK
Oracle
Linux
Server UEK 9
Sup
Sup
1
NS
NS
Oracle
Linux
Server UEK 8
Sup
Sup
Sup
Sup
Oracle
Linux
Server UEK 7
Sup
Sup
Sup
Sup
Debian
Debian
11
Sup
Sup
Sup
NS
Debian
10
Sup
Sup
Sup
Sup
Amazon
Amazon
Linux
2023
Sup
NS
NS
NS
Amazon
Linux
2
Sup
Sup
Sup
Sup
1
Support requires
CylancePROTECT Desktop
agent 3.1.1001 or later.