System requirements Skip Navigation

System requirements

Please ensure your system meets the requirements listed below before installing the application.
OS
This application has been tested with at least 4GB RAM and two or more CPU cores on the following x64 platforms:
  • Ubuntu
    14.04
  • Red Hat
    Enterprise Linux 7.2 Server
  • CentOS
    7
  • Windows
    Server 2012 R2
Splunk
This application has been tested with the following
Splunk
versions:
Tip for
Splunk
Version / Installation:
  • Not all
    Splunk
    versions interact with the app the same way. Using different browsers may help increase setup and navigation compatibility. For example, use
    Chrome
    for configuring TDR and
    Firefox
    to view menus:
    • http://<IP>:<PORT>/en-US/app/cylance_protect/ConfigureTDR
Network
Once-per day scripted inputs, such as threats.py, poll the Threat Data Report by connecting to the Threat Data Report URLs over port 443.
Syslog event forwarding from your
Cylance
Tenant to your
Splunk
deployment requires network configuration in the management console and a firewall rule on the
Splunk
deployment or a log forwarder.
Please refer to the SIEM and Syslog integration information at https://support.blackberry.com/community/s/article/66572