Planning upgrades for older CylancePROTECT Desktop Linux agents Skip Navigation

Planning upgrades for older
CylancePROTECT Desktop
Linux agents

Linux agent 1590 and higher
When upgrading from the
CylancePROTECT Desktop
Linux
agent 1580 and lower to agent 1590 and higher, the
Linux
open driver and agent driver must be installed before upgrading the agent. See Updating the Linux driver.
RHEL/CentOS 7.x (on agent 1460 or later), and 8.x:
Use the zone-based updating mechanism on the Update page in the console.
RHEL/CentOS 7.x (on agent 1450 or earlier), Ubuntu, Amazon, and SUSE:
The agent must be upgraded manually.
  1. Download the latest .rpm or .deb package from the console.
  2. Use the following command to upgrade the Linux agent:
    RHEL/CentOS:
    rpm -Uvh CylancePROTECT.version.rpm
    Ubuntu:
    dpkg -i cylance-protect.deb
    Amazon or SUSE:
    rpm -Uvh CylancePROTECT.rpm
  3. Use the following command to upgrade the Linux agent UI:
    RHEL/CentOS:
    rpm – Uvh CylancePROTECTUI.version.rpm
    Ubuntu:
    dpkg -i cylance-protect-ui.deb
    SUSE:
    rpm -Uvh CylancePROTECTUI.rpm