Install the RHEL/CentOS agent manually Skip Navigation

Install the RHEL/CentOS agent manually

  • Download the
    CylancePROTECT Desktop
    installation files from the management console. Go to
    Settings > Deployments
    , select the
    CylancePROTECT
    product, the target operating system, the agent version, and the file type. Click
    Download
    .
  • Get the installation token from the management console. Go to
    Settings > Application
    .
  • Root permission is required to install the
    Linux
    agent.
  1. Create the following file before you install the .rpm:
    /opt/cylance/config_defaults.txt
    For more information, see Create a configuration file.
  2. For 64-bit operating systems, you may need to install the 32-bit dependencies. Review the following table to determine if dependencies are required:
    Agent version
    OS version
    Description
    1560 or later
    RHEL/CentOS 8
    You do
    not
    need to install the 32-bit dependencies.
    1450 or later
    RHEL/CentOS 7
    You do
    not
    need to install the 32-bit dependencies.
    1440 or earlier
    RHEL/CentOS 7.x
    You must install the 32-bit dependencies.
    The agent is a 32-bit binary and requires 32-bit libraries to run.
  3. For agent version 1590 or later, use the following command to install the Linux open driver:
    rpm -ivh CylancePROTECTOpenDriver-version.rpm
    For agent version 1590 or later, the agent, agent UI, and the drivers are included in a .tgz file. Extract the open driver from the .tgz file and install it.
  4. For 1590 or higher, use the following command to install the Linux agent driver:
    rpm -ivh CylancePROTECTDriver-version.rpm
    For 1agent version 1590 or later, the agent, agent UI, and the drivers are included in a .tgz file. Extract the agent driver from the .tgz file and install it.
  5. Use the following command to install the Linux agent:
    rpm -ivh CylancePROTECT.version.rpm
    For agent version 1590 or later, the agent, agent UI, and the drivers are included in a .tgz file. Extract the agent from the .tgz file and install it.
  6. Use the following command to install the Linux agent UI (optional):
    rpm -ivh CylancePROTECTUI.version.rpm
    For agent version 1590 or later, the agent, agent UI, and the drivers are included in a .tgz file. Extract the agent UI from the .tgz file and install it.
Review the following:
  • CentOS 7.x also requires that you restart the GNOME shell in order to view the CylancePROTECT UI. You can do this by pressing Alt+F2, then type r, then press
    Enter
    .
  • GNOME 3.8, 3.10, 3.14, 3.18, and 3.20 are supported with Agent version 1590 or higher.
  • “Error:Multilib version problems found.” – If this error occurs when installing a package, then the corresponding 64-bit library must be installed or upgraded, along with the 32-bit library. This often means that the root cause is something else and multilib version checking is pointing out that there is a problem. For example:
    • You have an upgrade for sqlite which is missing some dependency that another package requires. Yum is trying to solve this by installing an older version of sqlite of the different architecture. If you exclude the bad architecture, yum will tell you what the root cause is (which package requires what). You can try redoing the upgrade with
      --exclude sqlite.otherarch
      . This should display an error message showing the root cause of the problem.
    • You have multiple architectures of sqlite installed, but yum can only see an upgrade for one of those architectures. If you don't need both architectures, you can remove the one with the missing update and everything will work.
    • You have duplicate versions of sqlite installed already. You can use "yum check" to show these errors.
    • To install or upgrade the matching SQLite library, use the following command: yum install sqlite.i686 sqlite
      This may also be a problem with dbus-libs, openssl, or libgcc. If so, replace sqlite with the correct library in the command above.