Java Runtime Environment Skip Navigation

Java
Runtime Environment

For information on how to upgrade JRE on
BlackBerry UEM
, visit support.blackberry.com/community to read article 37393.
Oracle Java SE Runtime Environment software is not packaged with
BlackBerry UEM
. For more information, visit support.blackberry.com/community to read article 54036.
Open JDK 8-based builds that are compatible with
Java
SE 8 are supported as an alternative to using Oracle JRE 8. For more information, visit support.blackberry.com/community to read article 52117.
Java
Runtime Environment (JRE)
Cloud
12.17
12.16
12.15
JRE 7 (latest update version, 64-bit)
NS
NS
NS
NS
JRE 8 (latest update version, 64-bit)
1
2
Sup
Sup
Sup
Sup
1
BlackBerry UEM has compatibility issues with JRE 8u291 and JRE 8u292. For more information, see Critical Issue Advisory: JRE versions 8u291 and 8u292 have compatibility issues with BlackBerry UEM 12.12 and later.
2
BlackBerry UEM has compatibility issues with JRE 8u331. For more information, see KB97875.