Configuring library version compliance

In a compliance profile or compliance policy, an administrator can enable the 
BlackBerry Dynamics
 library version verification compliance rule to specify an enforcement action if a 
BlackBerry Dynamics
 app is using a version of the 
BlackBerry Dynamics
 library that is not permitted. The available enforcement actions are "Do not allow 
BlackBerry Dynamics
 apps to run" and "Delete 
BlackBerry Dynamics
 app data."
In 
UEM
, by default the 
BlackBerry Dynamics
 library version verification compliance rule is not selected and all versions are permitted. An administrator can enable this option and select specific versions to disallow.
In standalone 
Good Control
 5.0, the following options are available:
  • Allow all 
    BlackBerry Dynamics
     library versions: Apps that use any version of the SDK library are allowed. If this option is enabled, the administrator cannot select specific versions to allow or disallow. By default, this option is disabled.
  • Allow unlisted 
    BlackBerry Dynamics
     library versions: Apps that use versions of the SDK library that are newer than the latest version listed in the compliance rule are allowed. The administrator can still allow or disallow specific versions of the library from the version list. By default, this option is enabled.
Consult with the 
UEM
 or 
Good Control
 administrator to ensure that the compliance rule is configured appropriately.