Skip Navigation

What's new in
BlackBerry AppSecure SDK
version 0.7 beta

Feature
Description
Rebranding of the SDK
The SDK was previously known as the BlackBerry Spark SDK. It has now been rebranded to the
BlackBerry AppSecure SDK
.
Changes to software requirements
  • The minimum required
    iOS
    version is now
    iOS
    14.
  • The minimum required
    Android
    OS version is now
    Android
    8.
  • The minimum required
    Android
    SDK API level is now 26.
Network security check
On
iOS
and
Android
devices, if the SDK is unable to connect to the
BlackBerry Protect
cloud services, it determines that the current network is not safe.
Insecure
Wi-Fi
check
On
Android
devices, the SDK periodically checks the properties of the current
Wi-Fi
access point to determine if it is secure.
Improvements to error handling
This release includes improvements to error handling when the SDK APIs are used before the library is properly initialized.