Skip Navigation

System requirements

To use
Microsoft Office 365
modern authentication with your
BlackBerry Dynamics
apps, you require the following:
  • Office 365
    ,
    Microsoft Exchange Online
    , or hybrid
    Microsoft Office 365
    and on-premises
    Microsoft Exchange Server
    *
  • BlackBerry UEM
    version 12.8 or later
  • BlackBerry Enterprise Mobility Server
    version 2.10 or later
    *
    Hybrid
    Microsoft Office 365
    and on-premises
    Microsoft Exchange Server
    environments are supported in
    BEMS
    3.2 or later.
  • The following are the apps that you require. To allow users in your environment to use the latest features and enhancements, it is recommended that users upgrade the
    BlackBerry Dynamics
    apps on their devices to the latest software versions.
    • BlackBerry Notes for Android
    • BlackBerry Notes for iOS
    • BlackBerry Tasks for Android
    • BlackBerry Tasks for iOS
    • BlackBerry Work for Android
    • BlackBerry Work for iOS
    • BlackBerry Work for macOS
    • BlackBerry Work for Windows
    • BlackBerry Connect
      for
      Android
    • BlackBerry Connect
      for
      iOS
  • Authentication server or identity provider requirements
    • Users must be able to authenticate using their email address or UPN. Other identifiers are not supported.
    • To support
      Windows
      Integrated Authentication or
      Kerberos
      Constrained Delegation, you must synchronize your on-premises
      Active Directory
      to
      Microsoft Azure Active Directory Connect
      , and the Username value in
      Azure
      AD must be the email address or UPN.
  • Modern authentication works as expected before you enable
    BlackBerry Dynamics
    apps. Verify the functionality by successfully opening a browser, navigating to outlook.office365.com, and entering the credentials of a user with a mailbox on
    Microsoft Exchange Online
    .