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Getting started
The BlackBerry® AtHoc® management system uses the IIM add-on module interface with Giant Voice (GV)
outdoor warning devices to enable wide-area Mass Notification System (MNS) broadcasts. Giant Voice features
can broadcast critical information using voice messages, wave files, musical tones, or text-to-speech (TTS)
conversion. Whelen GV supports outdoor Public Address (PA) systems that have large amplified speakers.
Typically, speakers are set on poles in an array that covers a specified area with enough acoustic sound to
override the ambient noise with emergency notification.

After the BlackBerry AtHoc management system is integrated with a Whelen Giant Voice System, operators
can disseminate emergency alerts to the siren system from the BlackBerry AtHoc management system. Alert
messages can be delivered using text-to-speech or pre-recorded audio files to up to three pre-defined target
zones by using the external call key inputs. A fourth external call key input is reserved for sending a "Cancel"
command to all poles.
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Product requirements
The following section describes the hardware and software requirements to install and configure the Whelen V2
Giant Voice system.

Hardware requirements

• Whelen E-2010 Central Control Station or Whelen E969 Siren Activation Encoder

Software requirements

• BlackBerry AtHoc release 7.9 or later
• .NET framework 4.6.1 and 6.0.x
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Specific usage data collection
Integration with a Whelen E-969 uses two Remote Inputs, while integration with an E-2010 uses four External Call
Key inputs. One input, Remote Input 2 or External Call Key 58, is always reserved for the “Cancel All” function,
leaving Remote Input 1 or External Call Keys 57, 59, and 60. The remaining functions are programmed as PA
(Public Address) commands forwarding the submitted message to an associated Remote Terminal Unit (RTU) or
target group.

These Remote Inputs and External Call Keys are programmed for Public Address use but unlike manual call keys,
the IIM provides the audio content instead of an operator using the microphone.

When an alert is received by the IIM:

• The IIM sequences the actuation of the relevant Remote Input or External Call Key and pauses
• The Base Station transmits the contents of the Remote Input or External Call Key
• The IIM plays the selected audio content
• The IIM actuates Remote Input 2 or External Call Key 58
• The Base Station transmits the contents of the Remote Input or External Call Key
• If additional External Call Keys are specified, the cycle repeats the sequence with the next specified External

Call Key

For detailed information about how to remote inputs for One Shot and Call Key activation, refer to the “Whelen
E-969 Encoder Installation and Operating Manual” (Whelen Engineering Company, Inc. 1995; Document #
04-0113056-01D), pages 14 to 15. Remote Input 1 should be programmed as PUBLIC ADDRESS to #### (all
poles) and Remote Input 2 as CANCEL to ####.

For detailed information about how to Program, Modify, Delete, Finish Call Key and Remote Input Call Keys, refer
to the “Whelen Operation & Installation Manual: Basic description and operation of the E-2010 Central Control
Station (Whelen Engineering Company, Inc. 1998; Document # 04-0113382-00C), pages 7 to 10. External Call Key
58 should always be programmed as “1-00-####-002” which cancels all poles and delays for 2 seconds.

There are several options when configuring External Call Keys 57, 59, and 60. In most cases, sites send all
emergency content, bugle calls, and voice messages to all poles simultaneously. In this case, External Call Key 57
should be programmed as “1-04-####-002” (PA all poles and delay for 2 seconds). If the site requires the ability
to send some content to an individual pole or a subset of poles, the remaining 2 External Call Keys, 59 and 60 (and
57 if all poles is not desired), can be programmed to target an individual or a subset instead of the “####” (all
poles) selection.

Whelen Dual Tone Multi Frequency (DTMF) Station Addressing is detailed in the Whelen® Engineering Company
Siren Configuration Software User’s Manual, Form No. 13595A (012304), pages 17 to 23. For the poles to be
grouped, they must meet the Whelen addressing scheme such that “#” wildcard characters can be used in an
address string. If they do not conform to grouping standards but the customer desires them to be grouped, the
site’s GV System Maintenance POC needs to perform work to re-address individual poles.

Care should be taken in the configuration of multiple External Call Key configurations that all poles in the giant
voice system are targetable by selecting one or more External Call Keys.

Also, consideration should be given to timely giant voice system activation. When multiple External Call Keys are
configured, the IIM sends the audio content to the addresses contained in each External Call Key sequentially and
not simultaneously. This can result in a significant delay to parts of the system during actual emergencies.

Because the Whelen v2 integration does not include “Key” functions, or the ability to specifically target recordings
stored at the poles, any recordings stored at the poles need to be provided as WAV files to be stored in the
BlackBerry AtHoc server. These WAV files should be converted to mono, compressed down to 8-bit or 16-bit
sampling, and have all frequencies below 400 Hz removed before uploading. However, WAV Windows PCM, 8 KHz
to 48 KHz, 8-bit or 16-bit, mono or stereo files will work.
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Note:  Audio files should be carefully edited to remove frequencies below 400 Hz. Sustained low frequencies can
cause damage to certain vendors’ electronic components.

For best results, any WAV file intended to be played by the IIM should be tested and verified prior to use in a live
alerting situation.

If the WAV file is greater than 2 MB in size, the Audio File Uploader tool, found under the Settings section, may
indicate an error. Contact BlackBerry AtHoc technical support for additional instructions on how to upload
oversized files.

If the GV system uses radio frequency (RF) communications between the Central Control Unit (CCU) and Remote
Terminal Units (RTU), you need to check the associated radio Push-To-Talk Time-Out-Timer setting. This setting
should be at set to 5 minutes or “infinite” to ensure that audio transmissions do not get cut off. Check with the
site’s GV System Maintenance or RF System Maintenance POC to ensure that this setting is correct.

 | Specific usage data collection | 8



Configure the Whelen v2 device
Configure the Whelen v2 gateway in the Settings section of the BlackBerry AtHoc management system to enable
the BlackBerry AtHoc alerts system to publish alerts through Whelen v2.

Configure the Whelen v2 device on the BlackBerry AtHoc application
server
Log in to the BlackBerry AtHoc management system and check the Delivery Gateways section to verify that the
Whelen v2 and XML Feed device gateways have been installed. If they are installed, skip this section.

1. Log in to the BlackBerry AtHoc application server as an administrator.
2. Navigate to the following folder <IWSAlerts Install Path>\ServerObjects\Tools and run the

AtHoc.Applications.Tools.InstallPackage.exe file. The Configure Device Support screen opens.
3. Select Whelen Giant Voice, v2 and Xml Feed.

4. Click Enable.
5. When the Installation Complete pop-up window is displayed, click OK.
6. Click Close.

Configure the delivery gateway
1. Log in to the BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click .
3. In the Devices section, click Whelen Giant Voice, v2.
4. On the Whelen Giant Voice, v2 page, click Copy default settings.
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5. In the CAP Parameter Defaults section, the Sender field displays "IWSAlerts". Remove "IWSAlerts" and
manually enter "BlackBerry AtHoc Alerts" in the Sender field:

6. Click Save.
7. In the navigation bar, click .
8. In the Devices section, click Xml Feed.
9. On the Xml Feed page, click Copy default settings.
10.In the Feed Source section, select End User.
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11.Click Save.

Enable the Whelen Giant Voice v2 device
1. In the navigation bar, click .
2. In the Devices section, click Devices.
3. On the Devices page, click the Mass Devices tab.
4. Click Whelen Giant Voice v2.
5. On the Whelen Giant Voice v2 page, click Edit.
6. In the Delivery Gateways section, click Add a Delivery Gateway > Whelen Giant Voice,v2.

7. In the Whelen Giant Voice,v2 row, click .
8. In the Configure Gateways window, check for XML code in the Configuration XML field. If the field is empty,

copy and paste the following code into the field:

<Configuration>
     <CapParams>
        <GVSystemType>Whelen2010v2</GVSystemType>
        <UnusedMode>0</UnusedMode>
        <KeyMode>4</KeyMode>
        <DefaultKeyCode>57</DefaultKeyCode>
        <DefaultKeyActivationCode>0</DefaultKeyActivationCode>
        <NoPARequired>0</NoPARequired>
        <PARequired>1</PARequired>
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        <ContentSource>GiantVoice</ContentSource>
        <PoleMode>0</PoleMode>
        <DefaultAllCall>0</DefaultAllCall>
        <AllMode>0</AllMode>
      </CapParams>
</Configuration>

9. Click Submit.
10.Click Save.
11.Click More Actions > Enable.

Configure the Xml Feed device
1. In the navigation bar, click  .
2. In the Devices section, click Devices.
3. On the Devices page, click the Mass Devices tab.
4. Click Xml Feed.
5. On the Xml Feed page, click Edit.
6. In the Delivery Gateways section, click Add a Delivery Gateway > Xml Feed.
7. In the Whelen Giant Voice,v2 row, click  .
8. In the Configure Gateway window, check for XML code in the Configuration XML field. If the field is empty,

copy and paste the following code into the field:

<Configuration>
              <DeviceType>FEED</DeviceType>
        </Configuration>

9. Click Submit.
10.Click Save.

Note:  You must configure the Xml Feed but are not required to enable it to use the Whelen Giant Voice v2 device.

Set up mass device endpoints (targets)
The process of setting up Mass Alert devices or endpoints involves the use of external call keys, a Whelen term
referring to E-969 or E-2010 encoder digital inputs. Each external call key is a set of instructions that is sent from
the encoder to siren poles. On the E-2010 encoder there are three variable modes and one static mode for the call
keys and each key is assigned a number. 57, 59, and 60 for variable mode inputs while 58 is a static mode input,
which is reserved for sending "Cancel All" commands to all poles. Each variable call key can be assigned to one
pole, a set of poles, or all poles.

Note:  Creation of custom attributes ATHOC-GV-KEYS and ATHOC-GV-TYPE is not required for Whelen Giant
Voice v2 Mass Communication users.

Create mass device external call key endpoints

Create a new Mass Device Endpoint for each static call key that is used (57, 59, and 60)

1. Log in to BlackBerry AtHoc management system as an administrator.
2. In the navigation bar, click the   (Settings) icon.
3. In the Devices section, click Mass Devices Endpoints.
4. Click New.
5. Select Whelen Giant Voice v2 from the list.
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6. In the General section, for the Display Name field, enter a name that describes the function of the associated
call key, so that it is easy to identify which key is for which function. For example, in the following image, Call
Key 57 is associated with Giant Voice All Poles.

7. In the Configuration section, select the Other option for Giant Voice type.
8. In Address field, enter one of the following call keys: “N,57”, “N,59”, or “N,60”. Ensure that there are no spaces

anywhere in the character string.
9. Click Save.
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Create and publish a Whelen Giant Voice alert template
Prerequisites

• Before you start sending test alerts through Whelen Giant Voice v2, consider the impact it has on everyone
within hearing distance of the poles you are using during the test.

• This process assumes that the IIM is not configured to download data from the BlackBerry AtHoc
management server and is not connected to the Giant Voice equipment.

• Consult with your POC as to the acceptable content of the test alert. For example, the word "test" should
appear at, or very near to, the start of the broadcast message.

• Although the initial use of this template is to test the data creation process, this template can be used during
the audio tuning phase after the IIM and Giant Voice hardware are connected.

To confirm that the Whelen Giant Voice v2 device is installed correctly on the BlackBerry AtHoc management
system, create a template.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. Click Alerts > Alert Templates.
3. On the Alert Templates page, click New.
4. On the New Template screen, in the Alert Template section, enter a template name and description.
5. Select a folder from the Folder list.
6. Select Available for Quick Publish.
7. In the Content section, enter the title and content of the alert.
8. In the Mass Devices section, select Whelen Giant Voice v2 and select an option from the pull-down menu.
9. In the top right corner of the Mass Devices section, click Options.
10.On the Mass Devices Options screen, select the Text to Speech and Alert Body or Custom Text options.
11.Click Apply.
12.In the Schedule section, change the Alert Duration to 15 minutes.
13.Click Preview and Save.
14.On the preview screen, review the settings and selections.
15.Click Save.
16.Click  to go to the Home page.
17.In the Quick Publish section, find the alert template you created.
18.Click Publish.
19.On the Review and Publish screen, review the settings and selections.
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20.Click Publish.

Verify the published alert

To verify that the alert was published successfully to the syndication feed, complete the following steps:

1. Open a browser and navigate to the following URL: https://<url>/syndication/cap_whelen_v2/
<vps-id>/capindex.

Where <url> is the base URL of the BlackBerry AtHoc management system (for example, https://
integration7.athoc.com) and <vps-id> is the 7 or 8-digit organization ID.

2. Copy the content in the <url> field into another browser. The “capIndex” XML format must be similar to the
content in the following image:

3. Verify the <addresses> and <code> and match with the following format. The “alert” XML format must be
similar to the content in the following image:

4. If any of the formatting does not match, review the Whelen Giant Voice, v2 Gateway XML content, and Mass
Communication Users’ Whelen Giant Voice v2 device addressing.
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Test pre-installation legacy functionality
Before making any modifications to the Whelen hardware programming or wiring, ensure that the legacy functions
are operational. Any pre-existing problems that were not identified during testing before making changes to wiring
or programming configuration could make troubleshooting more difficult after full system testing begins.

If the site has an E-2010 Central Control Station, have the customer or site operations POC initiate a Quiet Test
and Health Feedback function of the poles and observe the health statuses of each pole on the E-2010 display. In
addition, the site should initiate a Public Address function and make a manual microphone announcement.

If the site has an E-969 Encoder, health status feedback may not be observed. The site should initiate a Public
Address function and make a manual microphone announcement. In either case, the microphone announcement
should be observed as providing a loud and clear signal from an unobstructed listening position 100–200 yards
from a Giant Voice pole, preferably in line-of-site with the pole and not near any buildings or large structures.
Record any displayed faults or lack of clarity observed. It may only be possible to create audio with the new
integration on par with the legacy audio functionality. 
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Configure IIM IP connectivity
This section describes the steps to configure the IP Integration Module (IIM) to communicate with the BlackBerry
AtHoc Whelen v2 device.

Prerequisite

Ensure that the following packages are installed and configured before performing any tasks:

• Latest Whelen v2 BlackBerry AtHoc device package
• Latest Whelen v2 IIM capnode package

Uninstall the existing CapconService
1. Go to Program Files and open the capnode folder.
2. Right-click the UninstallCapCon-NT.bat file and select Run as administrator.
3. Go to Start > Run > Services.
4. Verify that the CapconService is uninstalled.

Uninstall the existing IIMAgent service
1. Go to Program Files and open the capnode folder.
2. Right-click the Uninstall_IIMAgent.bat file and select Run as administrator.
3. Go to Start > Run > Services.
4. Verify that the IIMAgent service is uninstalled.

Uninstall Java from IIM
Before you begin: Before uninstalling Java, make sure that the Java process is not running in the background.

1. Open the control panel.
2. Click Program and Features.
3. Right-click Java 8 Update XXX (64-bit) and click Uninstall.
4. Restart your system to ensure all background processes that use Java are stopped.
5. After the system restart, open a command prompt and type java -version. If Java is successfully uninstalled,

the following message is displayed:

C:\Users\COMM_AtHoc>java -version
'java' is not recognized as an internal or external command,
operable program or batch file.

Configure IIM IP connectivity
This section describes the steps to configure the IP Integration Module (IIM) to communicate with the BlackBerry
AtHoc Whelen v2 device.
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Prerequisite

Ensure that the following packages are installed and configured before performing any tasks:

• Latest Whelen v2 BlackBerry AtHoc device package
• Latest Whelen v2 IIM Capnode package

To work as part of the BlackBerry AtHoc system, IIM must be able to communicate with the BlackBerry AtHoc
server to download the CAP packets.

The initial configuration data you need to collect are:

• The BlackBerry AtHoc Alerts system base URL
• The BlackBerry AtHoc Alerts Organization ID
• Customer’s proxy server and port information

To find this information, use a local PC to log in to your local instance of the BlackBerry AtHoc management
system. The URL can be a base “https” address used to access a specific system. You can obtain the URL of
the system from the local system administrator or from the Blackberry Customer support team. Launch the
management console. The URL from the “https” to the last character before the third forward slash (/) is the “base
URL” of the system. For example, in the following URL address bar, the full URL for the sign-on page is: “https://
integration7.athoc.com/client/auth/login?ReturnUrl=%2fclient%2fathoc-iws”. The “base-URL” of the system is
“https://integration7.athoc.com”.

Navigate to the settings page of the browser and determine if you are using any type of Proxy server for routing
of internet traffic. For example, if the browser you are using is Microsoft Internet Explorer (IE), go to the LAN
settings, in IE, select Tools > Internet Options. On the Internet Options screen, click the Connections tab. At the
bottom of the window, click LAN settings.
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In the Proxy Server section, click the Advanced button. The Proxy Settings screen displays the Proxy Server
Address.

Record the proxy server address and the port number. You can now close these settings windows and exit IE.

Note:  It is also possible that your IE instance may not use proxy servers. If this is the case when you click the LAN
settings button, no proxy server is used for internet traffic on this network.
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Install the capnode in IIM
1. Download the capnode.zip file for Whelen.
2. Right-click the capnode.zip file and click Properties.
3. On the Properties dialog, in the Security section, select the Unblock option.
4. Click OK.
5. Right-click the capnode.zip file and select Extract All....
6. On the Select a Destination and Extract Files dialog, extract the files to C:\Program Files\capnode.

Install the CapconService
1. Go to Program Files and open the capnode folder.
2. Right-click the InstallUtilCapconService.bat file and select Run as administrator.
3. Go to Start > Run > Services.
4. Verify that the CapconService is installed.

Configure the system_private.config file
1. Open Microsoft Notepad as an administrator.
2. Click File > Open.
3. Navigate to C:\Program Files\capnode and change the file selection from “Text Documents (*.txt)” to “All

Files (*.*)”.
4. Select the system_private file.
5. Click Open.
6. Verify the following items in the system_private.config file:

a. The indexURL variable should be formatted similar to the following image. The base URL should be
followed by “/syndication/”, then the device gateway protocol ID (for example, CAP_Whelen_v2 for an
Whelen Giant Voice, v2 system), the Organization ID number, followed by "/capindex".
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b. The “#” at the beginning of a line in the system_private.config file is used to comment out an unused
line. The “#” should be removed from a line to use the variable.

7. Enter the proxy server and proxy port information you collected earlier in the proxyServer and proxyPort
parameters. If the settings on the machine that you tested with is set for “Automatic” in the proxy settings, the
settings for those two lines displays as follows:

• proxyServer=none
• proxyPort=8080

8. Update the CapPostingTarget variables to reflect the correct URL using the same base URL as in the
indexURL variable.

9. Click File > Save.
10.Close the system_private.config file.
11.Restart the CapconService.

Launch the Capcon system activity console (GUI)
1. Go to Program Files and open the capnode folder.
2. Right-click the runcapnode.bat file and select Run as administrator.

The Capcon system activity console opens.

Verify the Capcon system activity console (GUI)
1. Log in to the IIM console as an administrator. The Capcon console loads automatically.

The data in the Capcon System Activity console polls at the rate set by the delayBetweenRXpolls variable
in the system_private.config file. The default is set to 7 seconds. A message indicates the total number
of items in the index. The index number is the number of active alerts on the BlackBerry AtHoc system at that
time.

2. Verify that the IIM console does not show any new errors.
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3. Verify that the console icon in the task tray appears green ( ), indicating that the connectivity between the
IIM and the BlackBerry AtHoc alerts system is good. The console icon appears red ( ) if the CapconService is
stopped or not installed.

System tray icon menu

When the CapconService is running, the console icon in the task tray appears green ( ). Rick-click the tray icon to
perform any of the following tasks.

• Hide Console: Hide the Capcon console.
• Show Console: Display the Capcon console.
• Restart Service: Restart the CapconService.
• Quit Console: Close the Capcon console.
• Stop All: Close the Capcon console and stop the CapconService.
• Restart GUI: Restart the Capcon console and the system tray icon.
• Restart All: Restart the Capcon console, the system tray icon, and the CapconService.
• Logs: Open a list of log files in Capnode. Click to open a specific .log file.
• Configs: Open a list of configuration and property files. Click to open a specific .config or .prop file.

Troubleshoot Capcon console errors
If the Capcon system activity console indicates anything other than a total number of items in the index and a
number, or if the Capcon System Errors/Exceptions/Warnings console has content in red, this indicates that the
configuration has not been executed correctly.
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1. If the BlackBerry AtHoc management system, for example, "https://integration7.athoc.com/athoc-iws" is
available on IE on a local workstation, then the indexURL should also be available. Enter the indexURL in the
browser. For example, "https://integration7.athoc.com/syndication/cap_whelen_v2/2086867/capindex".
If there are no items in the syndication feed, an XML similar to the following image should be displayed:

If there are items in the feed, an XML similar to the following image should be displayed:

2. If connectivity is still not good, try commenting out the proxyServer and proxyPort variables.
3. If an HTTP or HTTPS error is displayed instead of XML, this may indicate a firewall or certificate issue or a

configuration problem with the BlackBerry AtHoc server syndication folder or subfolders.
4. Check the indexURL and proxy settings in the system_private.config file for any misspellings. If any line

have been misspelled, repeat the configuration steps.
5. Check the capnodelog file for errors. Open Windows Explorer by right-clicking on the IIM Start button and

navigate to C:/Program Files/capnode/capnodelogs and open the capnode.log file with Notepad.
Browse the file to find the time that the indexURL was changed and the CapCon service restarted.

6. Contact BlackBerry AtHoc customer support. Be prepared to provide the system_private.config and
capnode.log files and screen shots of the console screen and the BlackBerry AtHoc management console
pages.
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Test Post-installation final legacy functionality 
Once the wiring modifications needed to complete the integration are complete, the integrator must ensure that
the legacy functions of the original system are still operational. 

Note:  For instructions about the wiring modifications, contact the BlackBerry AtHoc Customer Support team and
request a copy of the BlackBerry AtHoc IIM Central Control Unit Interconnection Guide.

This is essentially the same test that was performed before the modifications were made. This test must be
performed again to ensure that any changes that were made have not created any problems with the legacy
system’s operation.

If the site has an E-2010 Central Control Station, have the customer or site operations POC initiate a Quiet Test
and Health Feedback function of the poles and observe the health statuses of each pole on the E-2010 display.
In addition, the site should initiate a Public Address broadcast, using the hand held microphone to make a test
announcement.

If the site has an E-969 Encoder, health status feedback may not be observed. The site should initiate a Public
Address broadcast, using the hand held microphone to make a test announcement. In either case, the microphone
announcement should be observed as providing a loud and clear signal from an unobstructed listening position
100–200 yards from a Giant Voice pole, preferably in line-of-site with the pole, and not near any buildings or large
structures.

Record any changes in operation since the pre-installation legacy functionality testing stage. If functionality does
not work as expected, review the work that was performed and verify that all wiring has been terminated as shown
in the wiring diagrams.
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Create and publish a pre-test alert template
Prerequisites

• Before you start sending test alerts through Whelen Giant Voice v2, consider the impact on everyone within
hearing distance of the poles you are using during the test.

• Consult with your POC as to the acceptable content, user targeting, and device selection of the pre-test
notification.

To targets end users using the desktop app, email, and messages to other devices to inform them of a Giant
Voice System test, create an alert template.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. Click Alerts > Alert Templates.
3. On the Alert Templates screen, click New.
4. On the New Template screen, in the Alert Template section, enter a template name and description.
5. Select a folder from the Folder list. Select Test if available.
6. Select Available for Quick Publish.
7. In the Content section, select Informational from the Severity list and Other from the Type list.
8. In the Content section, enter an alert title. The alert title can be the same as the template name. In the Body

field enter the text to be read by the text-to-speech. The body text should contain the details of the testing with
information such as the time testing will start and finish and any actions that should be taken as a result.

9. In the Target Users section, select the appropriate targeting group, individual users, or query to send the pre-
test notification to.

10.Click Select Personal Devices and then select Desktop App and Email - Personal.
11.In the top right corner of the Personal Devices section, click Options.
12.On the Personal Devices Options screen, select App Template and App Audio options.
13.Click Apply.
14.In the Schedule section, change the Alert Duration to the expected duration of the testing.
15.Click Preview and Save.
16.On the preview screen, review the settings and selections.
17.Click Save.
18.Click  to go to the Home page.
19.In the Quick Publish section, find the Giant Voice System Test Notification template.
20.Click Publish.
21.On the Review and Publish screen, click Publish.
22.To verify that the alert was published correctly, observe the receipt of desktop pop-up or email messages on

the POC workstation.

Adjust the WAV file audio level
IIM pre-recorded audio and text-to-speech audio tuning audio calibration must be performed in steps to calibrate
the individual audio levels for pre-recorded audio (WAV file) play and text-to-speech. Some adjustments can be
made by ear but can be more accurate if diagnostic tools are used. For radio-based systems, if a radio meter with
an FM deviation scale can be used, the accuracy of the tuning can be more precise. For non-radio-based systems,
a digital voltage meter can be used to read the levels of the transmitted audio.

Depending on the integration type, there can be different variables in the system_private.config file that
need to be tuned. For Whelen v2, the variables that typically require tuning are related to time delays, variables
with “before” or “after”, and text-to-speech attributes variables with “TTS”.
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1. Adjust the IIM Windows Audio Tool Tray Slider to approximately 25% as a starting point.

The Giant Voice System Test template should be edited to use pre-recorded audio content; typically the “Test
GVS” file. Observe the audio level and clarity in comparison with the manual activation baseline.

2. Log in to the BlackBerry AtHoc management system as an administrator.
3. In the Quick Publish section, search for the Giant Voice System Test template and click Edit.
4. In the Mass Devices section, select Whelen Giant Voice, v2.
5. In the top right corner of the Mass Devices section, click Options.
6. On the Mass Devices Options screen, select the Pre-recorded Audio option and select Test GVS from the list.
7. Click Apply.
8. Click Review and Publish.
9. On the Review and Publish screen, click Publish.
10.Observe the operations of the following:

• In the IIM console window, the number of items in index increases and that it starts processing the alert.
• The E-2010 or E-969 transmits the contents of External Call Key 57, 59, or 60 depending on selections made

in the BlackBerry AtHoc management system.
• The associated Giant Voice poles and the audio volume and clarity.

11.Adjust the IIM Windows Audio Tool Tray Slider to match the baseline audio level and clarity.
12.Repeat steps 2 to 11 until the pre-recorded audio sounds close in volume and clarity to manual microphone

announcements.

Adjust the text-to-Speech audio level and characteristics
The previously configured Giant Voice System Test template should have been configured to use POC-approved
verbiage and Text-to-Speech. Observe the audio level and clarity in comparison with the manual activation
baseline and make adjustments as required.

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. On the Home page, in the Quick Publish section, search for Giant Voice System Test and then click Edit.
3. Click Review and Publish.
4. On the Review and Publish screen, review the settings and selections.
5. Click Publish.
6. Observe the operations of the following:

• In the IIM console window, the number of items in index increases and that it starts processing the alert.
• The E-2010 or E-969 transmits the contents of External Call Key 57, 59, or 60 depending on selections made

in the BlackBerry AtHoc management system.
• The associated Giant Voice poles and the audio volume and clarity.

7. Click Start > Run and type Notepad. Right-click on the Notepad icon and select Run as administrator and then
click OK.

8. Using Microsoft Notepad, open the system_private.config file located at C:\Program Files
\capnode\system_private.config.

Tip:  You can also use the TTS Config tab on the Capcon console to adjust the TTS audio characteristics and
levels. For more information, see Adjust TTS audio using the TTSConfig tab.

9. In the Notepad, find the following:

• encoder.SirenCentralEncoder.TTS_Volume variable and adjust up or down to match the baseline
audio level.

• encoder.SirenCentralEncoder.TTS_Speed variable and adjust up or down to adjust the rate of
speech. The speed variable is in words per minute.
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• encoder.SirenCentralEncoder.TTS_Pitch and encoder.SirenCentralEncoder.TTS_Range
variables and adjust up or down to adjust the pitch and inflection of the speaking voice.

10.Click File > Save.
11.Run another test and observe the audio characteristics.
12.Repeat steps 1 to 11 until the prerecorded audio sounds close in volume and the clarity to the baseline.

Adjust TTS audio using the TTSConfig tab
When you open the TTS Config tab on the Capcon console, the sliders have the values set in the
encoder.SirenCentralEncoder attribute in the system_private.config file.

1. Log in to the Capcon console.
2. Click the TTS Config tab.
3. Adjust any of the following sliders:

• Volume: Adjust up or down to match the baseline audio level.
• Words/Min: Adjust up or down to change the rate of speech. The speed variable is in words per minute.
• Pitch/Hz: Adjust the pitch of the speaking voice.
• Range: Adjust the inflection of the speaking voice.

4. Optionally, click Undo to undo the last slider adjustment.
5. Optionally, select a Synthesizer and Voice option.
6. Optionally, enter text in the text field and click Speak Text or Speak to test the adjustments.
7. Click Apply. The adjustments are applied and saved to the system_private.config file.

Adjust function sequencing
The previously configured Giant Voice System Test template should have been configured to use POC-approved
verbiage and Text-to-Speech. Observe the timing of the IIM, E-2010 or E-969 encoder. If the audio is being clipped
at the beginning or end or if there is a long delay before or after the audio, make adjustments to variables in the
system_private.config file to adjust the sequencing.

To adjust the function sequencing, complete the following steps:

1. Log in to the BlackBerry AtHoc management system as an administrator.
2. On the Home page, in the Quick Publish section, search for Giant Voice System Test and then click Edit.
3. Click Review and Publish to review the settings and selections.
4. On the Review and Publish screen, click Publish.
5. Observe the operations of the following:

• In the IIM console window, the number of items in index increases and that it starts processing the alert.
• The E-2010 or E-969 transmits the contents of External Call Key 57, 59, or 60 depending on selections made

in the BlackBerry AtHoc management system.
• The associated Giant Voice poles and the audio volume and clarity.

6. Using the Microsoft Notepad open the system_private.config file: C:\Program Files\capnode
\system_private.config
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7. In the Notepad file, find the following:

• encoder.SirenCentralEncoder.SirenCentralDriverWhelen.Delay_for_PAcode_TX variable
and adjust up or down to increase or decrease the delay between sending the content of the external call
key and beginning to turn on the relays. The default is 5000 ms.

• encoder.SirenCentralEncoder.ptt_before variable and adjust the delay between the relays
turning on and the beginning of the audio content. The default is 100 ms between R1 turning on and R3
turning on; 100 ms between R3 turning on and R4 turning on; and 1000 ms between R4 turning on and the
audio beginning to play.

• encoder.SirenCentralEncoder.ptt_after variable and adjust the delay between the audio content
finishing and the relays turning off. The default is 100 ms between audio finish and R4 turning off; 100 ms
between R4 turning off and R3 turning off; and 1000 ms between R3 turning off and R1 turning off.

8. Click File > Save. Close Notepad.
9. Using the Service Manager, restart CapCon services.
10.Run another test and observe the audio characteristics.
11.Repeat steps 1 to 10 until the prerecorded audio sounds close in volume and the clarity to the baseline.
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Appendix: Differences between Java and .NET GUI
Panel Java .NET

Output tab Title panel No change No change

CapCon System Activity
console

No change No change

CapconSystem Errors/
Exceptions/Warnings
console

No change No change

Post Log Files button — The PostLogFile has no
function.

TTS Config tab Slider panel/Top panel 1. Includes sliders for
voice, speed, pitch,
and range.

2. There is no option to
see the current pin
value of sliders.

3. There is no option
to set or change the
slider value.

4. For Speak test from
the GUI, you must
click Apply every time
you want to change a
slider value.

5. The Undo button
reloads the saved
values from the
system_private.config
file and sets the
those values to the
sliders.

6. The Default button
sets the sliders to
their default values:
20,100,100, and 10.

1. Includes sliders
for voice, speed,
pitch, and range. No
change.

2. Includes a text box
at the top of each
slider that shows the
current pin value.

3. The slider value can
be adjusted from a
text box at the top
of each slider. Enter
an integer value in
the text box to set
the slider pin to that
value.

4. You do not need
to click Apply to
perform a Speak
test from the GUI. The
Apply button saves
the current slider
pin values to the
system_private.config
file.

5. The Undo button sets
the last applied value
of the sliders.

6. The Default button
sets the sliders to
their  default values:
60,100,100, and 10.

Synthesizer drop-down
menu

No change No change
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Panel Java .NET

Voice drop-down menu The Voice  drop-down
menu has two names:
Kate and Paul.

The Voice  drop-down
menu has one name:
Paul. Kate has been
removed.

Text panel No change No change

System tray icon — 1. No pop-up
notifications are
displayed.

2. When IIM is offline
(the CapconService
is stopped), no
notification is
displayed. The system
tray icon color does
not change.

3. The Wrapper.log
menu item appears in
the system tray.

4. The system tray icon
has a Restart GUI
menu item.

5. There is no UI console
log file.

6. The system tray icon
does not have the
BlackBerry logo.

1. Pop-up notifications
are displayed.

2. When IIM is offline,
an IIM is offline
pop-up notification
is displayed. The
system tray icon color
changes to red ( .)

3. The Wrapper.log
menu item was
removed from the
system tray.

4. The Restart GUI menu
item was renamed to 
Restart Console.

5. The console log file
has entries for each
action initiated from
the system tray menu.

6. The system tray icon
has the BlackBerry
logo in the green,
yellow, and red icons.
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Panel Java .NET

CapCon Console main
window (Form)

— 1. There is no .exe file.
2. To run the Java GUI,

you must have the
runcapnode.bat file.

3. There is no AtHoc
icon on the Java
executable.

4. There is no option
to pin the Capcon
console to the
taskbar.

1. There is an .exe file.
2. To run the .NET GUI,

double-click the
CapConConsole.exe
or the runcapnode.bat
file. The .NET GUI
can also be run by
double-clicking the
desktop shortcut
which is created
automatically after
the first run of the
Capcon console.

3. There is an AtHoc
icon on the .NET
executable Capcon
Console.exe file.

4. The Capcon console
can be pinned to the
taskbar.
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BlackBerry AtHoc Customer Support Portal
BlackBerry AtHoc customers can obtain more information about BlackBerry AtHoc products or get answers to
questions about their BlackBerry AtHoc systems through the Customer Support Portal:

https://www.blackberry.com/us/en/support/enterpriseapps/athoc

The BlackBerry AtHoc Customer Support Portal also provides support via computer-based training, operator
checklists, best practice resources, reference manuals, and user guides.
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Documentation feedback
The BlackBerry AtHoc documentation team strives to provide accurate, useful, and up-to-date technical
documentation. If you have any feedback or comments about BlackBerry AtHoc documentation, email
athocdocfeedback@blackberry.com. Please include the name and version number of the document in your email.

To view additional BlackBerry AtHoc documentation, visit https://docs.blackberry.com/en/id-comm-collab/
blackberry-athoc. To view the BlackBerry AtHoc Quick Action Guides, see https://docs.blackberry.com/en/id-
comm-collab/blackberry-athoc/Quick-action-guides/latest.

For more information about BlackBerry AtHoc products or if you need answers to questions about your BlackBerry
AtHoc system, visit the Customer Support Portal at https://www.blackberry.com/us/en/support/enterpriseapps/
athoc.
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subsidiaries and/or affiliates, used under license, and the exclusive rights to such trademarks are expressly
reserved. All other trademarks are the property of their respective owners.

Patents, as applicable, identified at: www.blackberry.com/patents.

This documentation including all documentation incorporated by reference herein such as documentation
provided or made available on the BlackBerry website provided or made accessible "AS IS" and "AS AVAILABLE"
and without condition, endorsement, guarantee, representation, or warranty of any kind by BlackBerry Limited and
its affiliated companies ("BlackBerry") and BlackBerry assumes no responsibility for any typographical, technical,
or other inaccuracies, errors, or omissions in this documentation. In order to protect BlackBerry proprietary and
confidential information and/or trade secrets, this documentation may describe some aspects of BlackBerry
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BLACKBERRY BE LIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR ITS USE,
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PARTY PRODUCTS AND SERVICES REFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE
FOLLOWING DAMAGES: DIRECT, CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE,
OR AGGRAVATED DAMAGES, DAMAGES FOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY
EXPECTED SAVINGS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF BUSINESS
OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, FAILURES TO TRANSMIT OR RECEIVE ANY DATA,
PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN CONJUNCTION WITH BLACKBERRY PRODUCTS OR
SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF BLACKBERRY PRODUCTS OR SERVICES OR ANY PORTION
THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR
SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES
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WERE FORESEEN OR UNFORESEEN, AND EVEN IF BLACKBERRY HAS BEEN ADVISED OF THE POSSIBILITY OF
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, BLACKBERRY SHALL
HAVE NO OTHER OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO
YOU INCLUDING ANY LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE
OF THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF
CONTRACT, NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A
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OR OF ANY REMEDY CONTAINED HEREIN; AND (B) TO BLACKBERRY AND ITS AFFILIATED COMPANIES, THEIR
SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS (INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED
BLACKBERRY DISTRIBUTORS (ALSO INCLUDING AIRTIME SERVICE PROVIDERS) AND THEIR RESPECTIVE
DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR,
EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF BLACKBERRY OR ANY
AFFILIATES OF BLACKBERRY HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.

Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to
ensure that your airtime service provider has agreed to support all of their features. Some airtime service
providers might not offer Internet browsing functionality with a subscription to the BlackBerry® Internet Service.
Check with your service provider for availability, roaming arrangements, service plans and features. Installation
or use of Third Party Products and Services with BlackBerry's products and services may require one or more
patent, trademark, copyright, or other licenses in order to avoid infringement or violation of third party rights. You
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licenses are required to do so. If required you are responsible for acquiring them. You should not install or use
Third Party Products and Services until all necessary licenses have been acquired. Any Third Party Products and
Services that are provided with BlackBerry's products and services are provided as a convenience to you and are
provided "AS IS" with no express or implied conditions, endorsements, guarantees, representations, or warranties
of any kind by BlackBerry and BlackBerry assumes no liability whatsoever, in relation thereto. Your use of Third
Party Products and Services shall be governed by and subject to you agreeing to the terms of separate licenses
and other agreements applicable thereto with third parties, except to the extent expressly covered by a license or
other agreement with BlackBerry.

The terms of use of any BlackBerry product or service are set out in a separate license or other agreement with
BlackBerry applicable thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS
WRITTEN AGREEMENTS OR WARRANTIES PROVIDED BY BLACKBERRY FOR PORTIONS OF ANY BLACKBERRY
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