Requisitos para desenvolvedores

Como os aplicativos comectados do BlackBerry Messenger são suportados só em BlackBerry executando o Software BlackBerry Device Software 5.0 ou posterior, é recomendado que você use o BlackBerry Messenger SDK junto com o BlackBerry Java SDK 5.0 ou posterior. Para fazer download do BlackBerry Java SDK ou das ferramentas de desenvolvimento associadas, visite http://na.blackberry.com/eng/developers/javaappdev/devtools.jsp.

Todos os aplicativos criados na plataforma do BBM devem ser distribuídos aos usuários do BlackBerry por meio da loja on-line do BlackBerry App World, embora um aplicativo possa ser carregado diretamente em um aparelho BlackBerry para propósitos de testes. Os aplicativos carregados diretamente no aparelho são considerados pela plataforma do BBM como temporários e são restringidos a um máximo de 100 usuários. Após um aplicativo ser disponibilizado no BlackBerry App World, não há nenhum limite no número de usuários.

Para distribuir um aplicativo por meio do BlackBerry App World, os desenvolvedores devem criar uma conta de associação para solicitar acesso ao portal do fornecedor. Para obter mais informações sobre como tornar-se um membro, visite http://na.blackberry.com/eng/developers/appworld/.

Todos os aplicativos que usam a plataforma do BBM estão sujeitos a limitações do código de conduta para evitar uso indevido da plataforma e proteger a privacidade do usuário. A Research In Motion reserva-se o direito de remover aplicativos que sejam potencialmente mal-intencionados ou estejam utilizando de forma indevida ou sobrecarregando a plataforma. Os aplicativos devem permitir que os usuários notifiquem a plataforma do BBM se o aplicativo executar qualquer ação iniciada pelo usuário sem o consentimento do usuário.

Próximo tópico: Enviar comentários

Estas informações foram úteis? Gostaríamos de receber seus comentários.