Suporte a APIs Java padrão

O BlackBerry® Java® SDK inclui APIs Java® ME e também APIs específicas BlackBerry. A seguir, é apresentado um resumo dos JSRs suportados:

  • JSR 30: Connected Limited Device Configuration (CLDC) versão 1.0 (suportado em aparelhos com o BlackBerry® Device Software versão 4.6.1 ou anterior)

  • JSR 37: Mobile Information Device Profile (MIDP) versão 1.0

  • JSR 75: Portable Optional Packages para suporte à Plataforma J2ME (PDAP) para PIM APIs e File Connection API para Java ME

  • JSR 82: Java APIs para Bluetooth®

  • JSR 118: Mobile Information Device Profile (MIDP) versão 2.1

  • JSR 120: Wireless Messaging API (WMA) versão 1.1

  • JSR 135: Mobile Media APIs (MM API) versão 1.1

  • JSR 139: Connected Limited Device Configuration (CLDC) versão 1.1

  • JSR 172: J2ME Web Services

  • JSR 177: Security and Trust Services API para J2ME (SATSA-APDU)

  • JSR 179: Location API para Java ME

  • JSR 185: Java Technology for the Wireless Industry (JTWI)

  • JSR 205: Wireless Messaging API 2.0 (WMA)

  • JSR 211: Content Handler API (CHAPI)

  • JSR 226: Scalable 2D Vector Graphics API para Java ME (SVG)

  • JSR 234: Advanced Multimedia Supplements (AMMS)

  • JSR 238: Mobile Internationalization API

  • JSR 239: Java Bindings para OpenGL® ES API (em alguns aparelhos)

Próximo tópico: Enviar comentários
Tópico anterior: APIs de segurança

Estas informações foram úteis? Gostaríamos de receber seus comentários.