Requirements

  • at least 650 KB of application storage
  • BlackBerry® Device Software 5.0 or later

Was this information helpful? Send us your comments.