Help Center

Local Navigation

Export to an SVG file

When you export your content to .svg format, you can compile the content to make it available for play on the BlackBerry® Browser. Refer to the SVG for BlackBerry Reference for more information on SVG.
  1. Click File > Export > SVG.
  2. In the Information section, specify how you want to update your SVG content.

    Field

    Description

    Update

    View information on the file properties after making changes to other properties on the dialog box by clicking the Update button.

    Live Update

    Select this check box to update the information automatically.

    Tip: If your computer has a slow processor, you might experience slower processing when using Live Update.

  3. On the Image tab, specify the file title and properties.

    Field

    Description

    Title

    Specify a title for the animation.

    Description

    Specify a description for the animation.

    Allow Zoom and Pan

    Enable zooming and panning.

    Export All Layers

    Export all layers of the animation. If this option is not selected, only visible layers are exported.

    Dimensions in %

    Specify the dimensions for the animation as a percentage. Ensure that you use this option for web-based content.

  4. On the Image tab, specify whether you want to export your images in .gif or .png format.

    Image type

    Option

    Description

    GIF

    Interlace

    When you select this check box, images first appear blurry and become sharper as they are downloaded. When Interlace is cleared, images appear gradually, top to bottom, as they are downloaded.

    With still .gif images, interlacing enables users with slow connections to click past an image they are not interested in viewing without having to download the whole image. Interlacing is not recommended for animated .gifs.

    PNG

    Color Mode

    Set the color palette.

     

    Interlace

    See above for description of Interlace.

     

    Filter

    • None compresses the image without a filter. This option is recommended for indexed-color and bitmap-mode images.
    • Sub optimizes the compression of images with even horizontal patterns or blends.
    • Up optimizes the compression of images with even vertical patterns.
    • Average optimizes the compression of low-level noise by averaging the color values of adjacent pixels.
    • Path optimizes the compression of low-level noise by reassigning adjacent color values.
    • All applies the filter—Sub, Up, Average, or Path—that is best-suited for the image. Select All if you are unsure of which filter to use.
     

    Compression

    Specify a method to reduce the file size.

  5. In the Color Reduction section, adjust the color settings of your exported file.

    Field

    Description

    Palette

    Determine which set of 256 (or fewer) colors is used in the exported animation

    • Adaptive automatically selects a set of colors that best approximate the original.
    • Web-safe uses a standard set of 216 colors. Web-safe colors are recommended for BlackBerry devices.
    Colors

    Set the number of colors used in the exported animation.

    Depending on the types of objects used, setting this field below 256 can seriously degrade image quality. However, reducing the number of colors can often significantly reduce file size.

    Color Reduction Set how the Plazmic® Composer reduces the number of colors for export. Experiment with both methods to determine which produces the best image.
    Dithering Dithering might improve image quality. Selecting this option increases your file size.
  6. To name and save the current export settings for later use or to load a previously saved group of settings, select the Save current settings when closing check box.
  7. Click OK.

Index


Was this information helpful? Send us your comments.